[WordPress] バージョン更新したら「Fatal error: Cannot redeclare get_language_attributes()」エラーが発生

Pocket
LINEで送る

久しぶりにWordpressのバージョンを更新したところ以下のエラーが表示されるようになった。

Fatal error: Cannot redeclare get_language_attributes() (previously declared in /wp-includes/general-template.php:2624) in //wp-content/plugins/wp-ban/wp-ban.php on line 249

原因

導入している「wp-ban」のプラグインとWordpressのバージョン不一致によるものでした。

対応

  1. 以下URLより最新の「wp-ban」プラグインをダウンロードする。
    https://downloads.wordpress.org/plugin/wp-ban.1.66.zip
  2. ダウンロードしたプラグインを回答して以下のフォルダに上書き
    [wordpress]/wp-content/plugins/wp-ban/
    ※念のためにフォルダを退避してから作業しましたが特に大きな問題はありませんでした。

上記対応で再度アクセスすることで正常にサイトが表示されました。
事前に検証サイトで確認できるようにしておいたほうが良いですね。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

この記事のトラックバック用URL